logo
Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
damo  
#1 Posted : Tuesday, June 23, 2015 3:42:34 PM(UTC)
damo

Rank: Member

Groups: Registered, Registered Users, Subscribers
Joined: 10/29/2005(UTC)
Posts: 25

Thanks: 2 times
Was thanked: 4 time(s) in 2 post(s)

Hi, I've noticed that the newer Metastock plugins will not run on Metastock versions 8 to 11, they will only run on v12 and above. Does anyone know how I can get a newer plugin to run on Metastock 11?

An example of this situation is the free Metstock Haguro plugin. The plugin installer will not install on Metastock versions 8 to 11. As most of the formula for these plugins are located in an external dll, in theory the older Metastocks should be able to call on and execute the dll file. Does anyone know of a workaround?

 

Thanks in advance.

mstt  
#2 Posted : Wednesday, June 24, 2015 2:52:11 AM(UTC)
mstt

Rank: Advanced Member

Groups: Registered, Registered Users, Subscribers
Joined: 7/25/2005(UTC)
Posts: 1,042

Was thanked: 57 time(s) in 54 post(s)
Hi damo My guess is that any standard MetaStock code used in the plugin (and stored as a *.DTA file) was created in MetaStock 12, and version 12 DTA files cannot be installed on older versions. If the DTA files are delivered in an EXE file then the EXE is unlikely to run to completion either. It used to be that a DTA file could be installed on the most recent previous version of MS simply by changing the version number in the DTA name. For example the MS91EXPL.DTA could be changed to MS90EXPL.DTA and then install usually without any problems on MS 9.0. Similarly an MS 9.0 generated MS90EXPL.DTA file could be changed to MS81EXPL.DTA and installed on MS 8.1. Somehow I doubt that knowing this is going to help in your present situation as I imagine that MetaStock would not want to make MS 12 tools available for earlier versions anyway. As for the DLL I really wouldn't know what versions of MetaStock would run it if the basic MFL code was available. Roy
MS Support  
#3 Posted : Wednesday, June 24, 2015 5:04:32 PM(UTC)
MS Support

Rank: Advanced Member

Groups: Moderators, Registered, Registered Users, Subscribers
Joined: 10/8/2010(UTC)
Posts: 1,539

Thanks: 47 times
Was thanked: 122 time(s) in 118 post(s)
Hi, What Roy describes is correct when not much was changing in regards to our formula language and tools. Once we started making enhancements to the tools (such as adding extra columns into the Explorer, increasing the formula limit, etc.) this unsupported 'trick' became even less reliable. Keep in mind it is not just "formula" changes that matter in regards to being able to import and export formulas. There are structural factors (such as using columns A through L in the Explorer whereas older versions of MetaStock only had columns A through F) that come into play even if those formulas are not utilizing these structural changes. We continue to keep backwards compatibility in mind whenever possible but maintaining 'forwards compatibility' can be difficult and is not very cost effective. You can always try what Roy described, but MetaStock cannot support that process in any capacity.
damo  
#4 Posted : Friday, June 26, 2015 3:08:29 PM(UTC)
damo

Rank: Member

Groups: Registered, Registered Users, Subscribers
Joined: 10/29/2005(UTC)
Posts: 25

Thanks: 2 times
Was thanked: 4 time(s) in 2 post(s)

Thanks Roy and support for taking the time out to respond, that pretty much explains and saves me a lot of time in a fruitless pursuit. It will probably save a lot of others with a similar idea.

 

Damo

Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.